Jump to content





Welcome to Ford Fusion Hybrid Forum


Sign In  Log in with Facebook

Create Account
Welcome to Ford Fusion Hybrid Forum, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of Ford Fusion Hybrid Forum by signing in or creating an account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members.
 
Guest Message by DevFuse

Posted Image
Register your Fusion Hybrid at the official Ford authorized registry here.


Photo
- - - - -

TSB 14-0099 - 03/05/2014 - MUSTY ODOR FROM A/C VENT ON INITIAL START UP


  • Please log in to reply
31 replies to this topic

#21 OFFLINE   GrySql

GrySql

    Fusion Hybrid Fanatic

  • Fusion Hybrid Member
  • 3,168 posts
  • Region:Decline
  • Location:So Cal
  • Current Vehicle:Yes
  • My Hybrid's Year:Decline

Posted 22 April 2015 - 08:31 PM

It's April now and like I said in my previous post, I used the A/C for the first time since October 2014 when we had an 80 degree day last week.

That same musty odor came shooting out of my vents as soon as I turned the A/C on.

I'm not going to use the A/C again until I bring it into the dealer so they can get a whiff of that foul smell.

I'm due for an oil change soon and need some other warranty work done, so it won't be too long until I can report back if the dealer refuses to perform the TSB work again!

Get Meagan, our Ford Rep, on the case before you go. 


  • hybridbear likes this
The Time Machine....
'13 FFH SE - Platinum White
Custom ordered, build date: 11/30/12, delivered: 12/12/12 - Sold: 09/05/15
 







Lose this advertisement by becoming a member. Click here to create a free account.


#22 OFFLINE   FordService

FordService

    Fusion Hybrid Enthusiast

  • Official Ford Motor Co.
  • 410 posts
  • Region:Decline
  • Location:Dearborn, Michigan
  • Current Vehicle:Model T
  • My Hybrid's Year:Decline

Posted 27 April 2015 - 10:55 AM

Is this on just Fusions?  My wife has a 2013 C-MAX and it smells really bad.  They wanted to charge her $98 for some deodorizing stuff they were going to spray. 

Has the smell gone away since your post? Please let me know, along with the mileage, and I'll check out some options.

 

It's April now and like I said in my previous post, I used the A/C for the first time since October 2014 when we had an 80 degree day last week.

 

That same musty odor came shooting out of my vents as soon as I turned the A/C on.

 

I'm not going to use the A/C again until I bring it into the dealer so they can get a whiff of that foul smell.

 

I'm due for an oil change soon and need some other warranty work done, so it won't be too long until I can report back if the dealer refuses to perform the TSB work again!

Once you have an appointment set up, please send me a private message with your VIN, mileage, best daytime phone number, full name, and dealer name/location.

 

Get Meagan, our Ford Rep, on the case before you go. 

Thanks!

 

Meagan



#23 OFFLINE   sunnychaser

sunnychaser

    New Member

  • Fusion Hybrid Member
  • 1 posts
  • Region:U.S. Southern Plains
  • Location:Texas
  • Current Vehicle:2013 Ford Fusion Hybrid Titanium
  • My Hybrid's Year:2013

Posted 15 July 2015 - 01:18 PM

I bought my car used in April (it's a 2013). The bad smell from the a/c I thought was from the cabin air filter so I took it in for 20K service (which includes the filter). They said that the filter was not causing the smell and they would order parts and call me in 2 weeks to install. 3 weeks later, I called to see if the parts were in and was told there was no record of any parts ordered for my car and that I could check with the service manager the next day and set a time to have deodorizer liquid run through my system. I spoke with the service Mgr the next day and he said that they DID have parts there, but wouldn't know which ones they needed until they took the car apart. I dropped my car off the following business day for what I was told would be a 6-7 hour job. It was ready 2 days later (they also reprogrammed the power train control module and possibly replaced the steering gear bolt). The paperwork says they performed TSB 412-0 with odor treatment. The only parts used were deodorizer and a filter. Can I take it back and demand that they replace the housing as stated in the TSB 14-0099, or is TSB 412-0 the new fix? I hate to have that awful smell come back later.

#24 OFFLINE   GrySql

GrySql

    Fusion Hybrid Fanatic

  • Fusion Hybrid Member
  • 3,168 posts
  • Region:Decline
  • Location:So Cal
  • Current Vehicle:Yes
  • My Hybrid's Year:Decline

Posted 16 July 2015 - 04:09 PM

I bought my car used in April (it's a 2013). The bad smell from the a/c I thought was from the cabin air filter so I took it in for 20K service (which includes the filter). They said that the filter was not causing the smell and they would order parts and call me in 2 weeks to install. 3 weeks later, I called to see if the parts were in and was told there was no record of any parts ordered for my car and that I could check with the service manager the next day and set a time to have deodorizer liquid run through my system. I spoke with the service Mgr the next day and he said that they DID have parts there, but wouldn't know which ones they needed until they took the car apart. I dropped my car off the following business day for what I was told would be a 6-7 hour job. It was ready 2 days later (they also reprogrammed the power train control module and possibly replaced the steering gear bolt). The paperwork says they performed TSB 412-0 with odor treatment. The only parts used were deodorizer and a filter. Can I take it back and demand that they replace the housing as stated in the TSB 14-0099, or is TSB 412-0 the new fix? I hate to have that awful smell come back later.

Hi, welcome to the Forum!

If the odor treatment works, fine - if not, you might need some help working with your Dealer.  The musty odor has to be obvious to the Service Advisor.

Send a Personal Message (PM) to Meagan, our on-site Ford Customer Service Rep here:  http://fordfusionhyb...05-fordservice/

 

Whatever you do don't delay past the 3 year/36 month Ford Warranty, after that Ford won't fix it.


  • zebmeat likes this
The Time Machine....
'13 FFH SE - Platinum White
Custom ordered, build date: 11/30/12, delivered: 12/12/12 - Sold: 09/05/15
 

#25 OFFLINE   FordService

FordService

    Fusion Hybrid Enthusiast

  • Official Ford Motor Co.
  • 410 posts
  • Region:Decline
  • Location:Dearborn, Michigan
  • Current Vehicle:Model T
  • My Hybrid's Year:Decline

Posted 17 July 2015 - 03:32 PM

...Send a Personal Message (PM) to Meagan, our on-site Ford Customer Service Rep here:  http://fordfusionhyb...05-fordservice/...

 

Thanks!

 

Meagan



#26 OFFLINE   rjmaggio

rjmaggio

    New Member

  • Fusion Hybrid Member
  • 1 posts
  • Region:U.S. Southern Atlantic
  • Location:bradenton
  • Current Vehicle:2014 Fusion Energi
  • My Hybrid's Year:2014

Posted 17 December 2015 - 04:06 AM

Same problem. Just bought a 2014 Energi new off the lot. They changed the cabin air filter already, and the stated I should bring the car in, and the will run an ionizer in it for several hours. After reading these posts, and the TSB, I believe the ionizer will not fix the problem. I an counting on my dealer to do the proper TSB fix. I'll let you know how it goes when I bring it in in January.

Isn't it time Ford corrected this issue, before putting the cars on the street?



#27 OFFLINE   hytibill

hytibill

    New Member

  • Fusion Hybrid Member
  • 46 posts
  • Region:U.S. Northeast
  • Location:New York
  • Current Vehicle:2013 Ford Fusion Hybrid Titanium

Posted 22 December 2015 - 01:01 PM

This is ridiculous. I got my car repaired under the TSB but it's starting to smell again. Seriously? 



#28 OFFLINE   gkinla

gkinla

    Fusion Hybrid Enthusiast

  • Fusion Hybrid Member
  • 339 posts
  • Region:U.S. Pacific Coast
  • Location:Los Angeles
  • Current Vehicle:2016 Fusion Energi
  • My Hybrid's Year:2016

Posted 22 December 2015 - 08:47 PM

This is ridiculous. I got my car repaired under the TSB but it's starting to smell again. Seriously? 

 

Like you, I got my FFH repaired under the TSB and it's starting to smell again. It's an in your face smell, not just a mild odor.  I'm working with my dealer to get it resolved. I took it back in just before the BTB warranty ended. Someone on here will say they all smell, my wife's 2010 Prius with 55,000 miles has no odor. My 2010 FFH with 65,000 miles, had no odor. Owned a 1985 Mazda for 10 years and 120,000 miles, no odor. I guess some do and some don't. I've never experienced it with my cars. I'm pissed!



#29 OFFLINE   FordService

FordService

    Fusion Hybrid Enthusiast

  • Official Ford Motor Co.
  • 410 posts
  • Region:Decline
  • Location:Dearborn, Michigan
  • Current Vehicle:Model T
  • My Hybrid's Year:Decline

Posted 24 December 2015 - 09:40 AM

This is ridiculous. I got my car repaired under the TSB but it's starting to smell again. Seriously? 

 

Hi hytibill,

 

I recommend heading to your dealer to have this checked back out. Once you have an appointment set up, please let me know, along with your mileage.

 

Meagan



#30 OFFLINE   krbujak

krbujak

    New Member

  • Fusion Hybrid Member
  • 5 posts
  • Region:U.S. Great Lakes
  • Location:Illinois
  • Current Vehicle:Fusion SE Hybrid
  • My Hybrid's Year:2015

Posted 08 June 2016 - 10:30 AM

I have a 2015 FFH SE which was built in January 2015. It also exhibits a horrid smell of death when the A/C is operated. It's so bad that one of my passengers nearly threw up. I see that the TSB referenced in this thread applies to cars built through February 2014. Has anyone heard anything about a similar issue on cars built after Feb 2014?

 

Thanks!

-Keith



#31 OFFLINE   mwr

mwr

    Fusion Hybrid Enthusiast

  • Fusion Hybrid Member
  • 685 posts
  • Region:U.S. Pacific Coast
  • Location:San Francisco Bay Area
  • Current Vehicle:2015 FFH SE
  • My Hybrid's Year:2015

Posted 08 June 2016 - 11:53 AM

I have a 2015 FFH SE which was built in January 2015. It also exhibits a horrid smell of death when the A/C is operated. It's so bad that one of my passengers nearly threw up. I see that the TSB referenced in this thread applies to cars built through February 2014. Has anyone heard anything about a similar issue on cars built after Feb 2014?

 

Thanks!

-Keith

Really sorry to hear that. I bought my 2015 FFH in late October 2015, so it was probably one of the first 2015 models built. It now has 24,000 miles and I've had no issue at all with an A/C smell. In fact, that A/C smell problem was one of the reasons I waited until the 2015 models were out to buy my FFH.


Edited by mwr, 08 June 2016 - 11:54 AM.

IMG_2641c_160w.jpg


#32 OFFLINE   rwhgme

rwhgme

    Fusion Hybrid Member

  • Fusion Hybrid Member
  • 61 posts
  • Region:U.S. Northern Plains
  • Location:Shawnee,Ks
  • Current Vehicle:2015 Fusion Hybrid
  • My Hybrid's Year:2015

Posted 08 June 2016 - 01:52 PM

Under moderate acceleration I get a Sulphur smell..as if I have a catalytic converter problem. It occurs on entering a highway, or accelerating to pass a car. Any answers?

Edited by rwhgme, 08 June 2016 - 01:53 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Privacy Policy Terms of Service ·