Jump to content





Welcome to Ford Fusion Hybrid Forum


Sign In  Log in with Facebook

Create Account
Welcome to Ford Fusion Hybrid Forum, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of Ford Fusion Hybrid Forum by signing in or creating an account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members.
 
Guest Message by DevFuse

Posted Image
Register your Fusion Hybrid at the official Ford authorized registry here.


Photo
- - - - -

Fusion 2010 not starting - just cycles warnings on instrument panel

fusion 2010 not starting dashboard warning lights

  • Please log in to reply
2 replies to this topic

#1 OFFLINE   adamr

adamr

    New Member

  • Fusion Hybrid Member
  • 2 posts
  • Region:U.S. Northeast
  • Location:10940
  • Current Vehicle:2010 Ford Fusion Hybrid Sedan 2.5L
  • My Hybrid's Year:2010

Posted 27 October 2018 - 02:20 PM

Hi,

Fusion not starting. Cycles through insrtument panel. I've installed a new 12v Battery but still no luck. Any help much appreciated.

Thanks 

 



Edited by adamr, 09 December 2018 - 03:52 PM.








Lose this advertisement by becoming a member. Click here to create a free account.


#2 OFFLINE   markwilson66

markwilson66

    New Member

  • Fusion Hybrid Member
  • 24 posts
  • Location:San Juan Capistrano, CA

Posted 07 December 2018 - 11:53 AM

Sounds like dead battery (12v, low voltage).  Look at the indicator eye on top of battery under the hood, green = OK, orange = dead.
Happened to me after sitting for months waiting on takata airbag replacement.  I put it on a trickle charger for 24 hours and it's OK now.

 



#3 OFFLINE   adamr

adamr

    New Member

  • Fusion Hybrid Member
  • 2 posts
  • Region:U.S. Northeast
  • Location:10940
  • Current Vehicle:2010 Ford Fusion Hybrid Sedan 2.5L
  • My Hybrid's Year:2010

Posted 07 December 2018 - 01:08 PM

Thanks for your reply. I have tried installing a brand new 12v battery but no luck.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Privacy Policy Terms of Service ·